Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
zachsr  
#1 Posted : Wednesday, August 7, 2013 6:49:29 AM(UTC)
zachsr

Rank: Member

Groups: Registered
Joined: 8/6/2013(UTC)
Posts: 3

Hello,
I have searched and found some threads on this specific issue of my oven and broiler not working at all and found some recommendations on how to check but being a total newbie, I had a quick question. When I am testing the continuity on the gas regulator (after unplugging the three wires) am I placing the multi-meter on the actual regulator diodes to test? or the disconnected wires themselves? I have done a couple of checks. I placed the multimeter on the regulator with wires disconnected - common to broil gave me a zero reading and common to bake also gave me a zero reading. When i placed the multimeter on the wires themselves, I get about 220 resistance reading on both bake and broil. Is my regulator bad? I also placed the multimeter on the DSI board to check J1-1 and J1-4 to see if I get any readings after I hit the bake button - only noticed that the multimeter jumped just a little but never hit the 120 that I read about.
Anyone out there available to provide some guidance?

Thank you
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
sika25  
#2 Posted : Wednesday, August 7, 2013 8:45:33 AM(UTC)
sika25

Rank: Member

Groups: Registered
Joined: 7/27/2013(UTC)
Posts: 4

I have the same problem. The repair company I called are convinced it is the thermal fuse and will not come test the appliance until they have got the fuse in stock. I am confused as I haven't read any other posts suggesting this as an issue unless things fail after a self-cleaning cycle (which I hadn't done).
zachsr  
#3 Posted : Tuesday, September 3, 2013 12:41:44 PM(UTC)
zachsr

Rank: Member

Groups: Registered
Joined: 8/6/2013(UTC)
Posts: 3

Any experts out there willing to assist?
Thank you :)
zachsr  
#4 Posted : Monday, September 30, 2013 6:14:02 PM(UTC)
zachsr

Rank: Member

Groups: Registered
Joined: 8/6/2013(UTC)
Posts: 3

So I was able to get my oven and broiler working again by replacing the gas valve unit I purchased from appliancepartspros. Hope this anyone else out there with this issue.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.