Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
electric45mike  
#1 Posted : Thursday, December 20, 2007 12:29:45 PM(UTC)
electric45mike

Rank: Member

Groups: Registered
Joined: 12/20/2007(UTC)
Posts: 9

Dishwasher starts & runs normally but never drains the soapy water out. It has run over 2 hrs. without shutting down. I open door, hit cancel & shut door and it pumps the water out & shuts down. Checked the water temp at 118 degrees which should be good. All the valves & pump seem to work okay so I wonder if the control board has a problem.
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
Gene  
#2 Posted : Thursday, December 20, 2007 3:43:14 PM(UTC)
Gene

Rank: Advanced Member

Groups: Senior Expert
Joined: 7/19/2007(UTC)
Posts: 27,455

Was thanked: 2 time(s) in 2 post(s)
If the dishwasher did not switch to drain for such log time, the control board has to be replaced.

- The part number for the control board is AP3775964

- Here are the break down diagrams for the Kitchen Aid dishwasher Model KUDP01FLSS1

Good luck.
Gene.
electric45mike  
#3 Posted : Thursday, December 20, 2007 3:46:59 PM(UTC)
electric45mike

Rank: Member

Groups: Registered
Joined: 12/20/2007(UTC)
Posts: 9

Thanks Gene-that's what I suspected.
electric45mike
Gene  
#4 Posted : Thursday, December 20, 2007 3:50:46 PM(UTC)
Gene

Rank: Advanced Member

Groups: Senior Expert
Joined: 7/19/2007(UTC)
Posts: 27,455

Was thanked: 2 time(s) in 2 post(s)
Keep me updated, please.

Gene.
electric45mike  
#5 Posted : Thursday, December 20, 2007 5:41:58 PM(UTC)
electric45mike

Rank: Member

Groups: Registered
Joined: 12/20/2007(UTC)
Posts: 9

Gene,
I will keep you posted-I will have to order the control board. I noticed in one of your other threads that you mention tech sheets. Where can you find the for Kitchen Aid D/W?
Thanks,
Mike
Gene  
#6 Posted : Thursday, December 20, 2007 8:28:44 PM(UTC)
Gene

Rank: Advanced Member

Groups: Senior Expert
Joined: 7/19/2007(UTC)
Posts: 27,455

Was thanked: 2 time(s) in 2 post(s)
Hi Mike

The tech sheets for your dishwasher.

Gene.
electric45mike  
#7 Posted : Friday, December 21, 2007 5:39:58 PM(UTC)
electric45mike

Rank: Member

Groups: Registered
Joined: 12/20/2007(UTC)
Posts: 9

Thanks for the info Gene. I have ordered the part. S/B here maybe Wed.-Thur next week.
Mike
electric45mike  
#8 Posted : Saturday, December 29, 2007 7:43:55 AM(UTC)
electric45mike

Rank: Member

Groups: Registered
Joined: 12/20/2007(UTC)
Posts: 9

Gene,
I got the control board Thurs. & got it installed. The machine still runs over 2 hrs. but I was able to get into the diagnostics & the clean light started blinking 7 times, stopped & then repeated. I found a reference to this being the heating system so I ran it through with inlet water at 100 degrees & took several temp readings on the heating element. It never was above the water temp. I inspected the element & found a hole at the back of the element. I didn't pull the washer out & turn upside down to take resistance readings but just ordered an element, thermister & hi temp limit thermostat. Since I've got to pull it out to install the element, I'll check them out then. At least I'll have the parts if I need them. My thinking now is that if the heater was not working, the machine is trying to delay for heating the water with no success. Does that sound plausible? Parts should be here about Jan. 3-5. APP called yesterday & said the element washers were out of stock till next week. It looks like they provide the interior seal around the element legs so I was going to replace them just to be safe. I'll keep you posted. Thanks for your help.
Mike
electric45mike  
#9 Posted : Saturday, January 5, 2008 4:20:23 PM(UTC)
electric45mike

Rank: Member

Groups: Registered
Joined: 12/20/2007(UTC)
Posts: 9

Gene,
Just recvd heating system parts. Took element out & checked resistance & found it open. Checked hi temp limit thermostat & thermister- OK but replaced anyway since I had parts & D/W out. Reassembled & it runs & shuts down like new & even have some parts leftover.
Thanks for the help & best wishes for a Great New Year.
Mike
Gene  
#10 Posted : Saturday, January 5, 2008 8:22:55 PM(UTC)
Gene

Rank: Advanced Member

Groups: Senior Expert
Joined: 7/19/2007(UTC)
Posts: 27,455

Was thanked: 2 time(s) in 2 post(s)
Mike,

I'm glad you were able to fix it.

Happy New Year to you as well.

Gene.
Users browsing this topic
Similar Topics
Dishwasher keeps running as soon as door is closed (Dishwasher Repair)
by atamhank 12/22/2016 6:48:39 AM(UTC)
Dishwasher keeps Running (Dishwasher Repair)
by Edge27 2/24/2014 5:51:08 PM(UTC)
Dishwasher keeps running after going through Cycle (Dishwasher Repair)
by hodges_h 3/7/2011 12:15:03 PM(UTC)
Dishwasher keeps running (Dishwasher Repair)
by cfornecker 11/17/2009 5:18:55 AM(UTC)
Dishwasher keeps running & running (Dishwasher Repair)
by Steinmy 6/1/2009 6:01:05 AM(UTC)
dishwasher keeps running (Dishwasher Repair)
by bioislife 8/3/2007 5:18:59 AM(UTC)
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.