Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
yozzomp  
#1 Posted : Wednesday, December 5, 2018 1:27:04 PM(UTC)
yozzomp

Rank: Member

Groups: Registered
Joined: 12/5/2018(UTC)
Posts: 0
United States

Hello all,

I've been having this problem for quite some time and it's literally driving me crazy. My oven burners and broil work with no problem but when I use Bake, it will ignite (sometimes first try but not all the time) then when it hits the set temp, it will fail to re-ignite. I hear 3 clicks and the sound and smell of gas but it will not re-ignite, sometimes if I'm lucky, it will. I also see a spark on the igniter as well. First I replaced the Spark Control module and this did not fix the issue. I then replaced the bake igniter, still no luck. Could it be that I have a bad gas valve even though I hear and smell gas when it tries to ignite? Another thing that I've done was drill additional holes on the bake burner which also didn't work. I'm stumped... please help!

Edited by user Wednesday, December 5, 2018 1:29:35 PM(UTC)  | Reason: Not specified

Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.