Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
coachpelkey  
#1 Posted : Monday, April 7, 2014 2:39:46 PM(UTC)
coachpelkey

Rank: Member

Groups: Registered
Joined: 4/7/2014(UTC)
Posts: 1

I have an electric range Pro Line Series.

About 3 days ago I went to turn on the knob to boil some water and all 4 burners are not working, no light on no nothing.

The stove works ok, all the displays are working ok.

Any suggestions?

The stove itself is hard wired into the circuit box, the landlord ran it straight down to the box. Should I try and turn it off for a few minutes and turn it back on?

The knobs were touchy in the past, any nudge against them, turned the burner on.

Any help would be appreciated.

ryanpelkey@gmail.com

Thanks in advance.
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
sookeslayer  
#2 Posted : Friday, May 9, 2014 10:42:12 AM(UTC)
sookeslayer

Rank: Member

Groups: Registered
Joined: 5/9/2014(UTC)
Posts: 4

From the sounds of it the breakers for the elements is tripped. Do you have a stove fuse panel at the top of your burners (at the back). Each element is protected by fuses and these should be checked.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.