Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

2 Pages12>
New Topic Post Reply
Options
Go to last post Go to first unread
mattbiel  
#1 Posted : Monday, December 26, 2011 12:49:40 PM(UTC)
Quote
mattbiel

Rank: Member

Groups: Registered
Joined: 12/26/2011(UTC)
Posts: 2

I have a Viking 30" stove. All the burners light correctly with the electricity (no matches needed). However, the front right burner continues to click even after it is lit. I have read that it could be dirty or wet, but I have sprayed it out with canned air, I have removed the top plate part, and I have ran the burner for over 30 minutes and still it clicks. I would like to repair this myself if possible (can't really afford appliance repair). Can you help me with where to start?
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
vikingQAswami  
#2 Posted : Monday, January 2, 2012 6:50:24 PM(UTC)
Quote
vikingQAswami

Rank: Member

Groups: Registered
Joined: 1/2/2012(UTC)
Posts: 1

The fix to stop the ignition module clicking is probably related to a poor ground wire found poorly connected to the range top ignition module. Access the ignition module easily from the top of the range . The ground wire feeding the ignition module is probably not making good contact with the stove chassis.

The ignition module ground wire is found inside the protective case which houses the ignition module and all the common connections for each burner . It is located in the center portion of the range top.

Since the ignition module itself is totally plastic, the only way it can get a ground is from that single ground wire. (Green).
The range must have excellent bonding and grounding of the ignition module for it to function properly.

I locate the (green) ground wire to the sheet metal fastener that holds the common terminal strip(also found inside the ignition cover) to the chassis .
When I relocated the ground wire in this manner, the chronic problem ceased.
It is not too difficult to relocate that ground wire to make a better metal to metal bond. 4 Phillips screws on the ignition support panel and 4 Phillips screws to remove the ignition module cover.
Good luck. Unplug the range before you work on it.

mattbiel  
#3 Posted : Monday, January 16, 2012 7:58:55 PM(UTC)
Quote
mattbiel

Rank: Member

Groups: Registered
Joined: 12/26/2011(UTC)
Posts: 2

VikingQAswami, thank you so much for your reply. I was able to locate the single green ground wire and I see what you mean about it's factory location and how it can provide a poor ground. However, the other three burners work fine (stop clicking when lit) so I didn't think this was the issue. When I grounded the green wire to make sure it was firmly touching the chassis, I was able to confirm that this was not the issue because again, the other three burners work correctly, but the front right burner still clicks continuously after being lit.

I wanted to test out a couple things so I switched around the little white ignitor poles from back burner to front, and still the front burner clicks. Does that mean it's a problem with that blue plastic ignitor box? I looked online a replacement (Tytronics RI 120E-4) but can't find it anywhere. Is it something else?

Thank you!
VikTech  
#4 Posted : Thursday, November 1, 2012 6:03:10 PM(UTC)
Quote
VikTech

Rank: Member

Groups: Registered
Joined: 11/1/2012(UTC)
Posts: 33

switching the wires did nothing but confuse the module...

Remove the front and rear ignitor and swap them, leaving the wiring on the same burner. if the problem follows the ignitor then voila, you need a new ignitor. If the problem remains on the same burner, it is a faulty wire or module. Usually the module, but confirm that the wire is in good shape before buying a $100 module.
ClickityClack  
#5 Posted : Sunday, January 25, 2015 1:49:00 PM(UTC)
Quote
ClickityClack

Rank: Member

Groups: Registered
Joined: 1/25/2015(UTC)
Posts: 1

I was able to resolve a similar problem. I thought it was the module but after installing a new one ($$$) I still had the problem. I removed and inspected each wire from the controller to the ignitor. Some connections where so corroded they were green. One connector had broken wires. I polished the ignitor connection blade and the ignitor top. This was black and when I polished it, it was bright metal. My stove is a sealed top, and at first I thought it was a big problem to remove the aluminum ring that holds the ignitor, but the bronze part with the two holes unscrewed very easily. The aluminum ring then lights up, after it breaks free of the grease and dirt holding it in place. I used a bicycle spanner and used some spray can olive oil to loosen up some of the harder to remove bronze parts.
The ignitor must change its resistance or something once the gas is burning in order to cause the module to stop sending current to make the spark. I measured the cold ignitor and it was like 0.5 ohms. Maybe when it gets hot it shoots way up and that stops the module. If, for example you have another ignitor which is shorting due to grease and dirt and allows a low resistance to be seen by the module, then the module keeps on sparking Just my thoughts :)
thad@tbissell.com  
#6 Posted : Thursday, November 3, 2016 9:15:51 AM(UTC)
Quote
thad@tbissell.com

Rank: Member

Groups: Registered
Joined: 11/3/2016(UTC)
Posts: 1

In my case, I found that my single burner ignitor was not in direct contact with the flame from the burner (bent a little up and to the right). With needlenose plyers, I very carefully (as to not break the ceramic) bent the ignitor to be more in contact with the flame.
Platt  
#7 Posted : Tuesday, August 8, 2017 8:28:49 AM(UTC)
Quote
Platt

Rank: Member

Groups: Registered
Joined: 8/8/2017(UTC)
Posts: 1

Originally Posted by: mattbiel Go to Quoted Post
I have a Viking 30" stove. All the burners light correctly with the electricity (no matches needed). However, the front right burner continues to click even after it is lit. I have read that it could be dirty or wet, but I have sprayed it out with canned air, I have removed the top plate part, and I have ran the burner for over 30 minutes and still it clicks. I would like to repair this myself if possible (can't really afford appliance repair). Can you help me with where to start?

Wire brushing the igniters solved the problem of the continuous clicking. (Before the fix, the clicking would stop if I turned the right front burner off and just used the others.)
ima_losin  
#8 Posted : Saturday, August 15, 2020 8:35:01 AM(UTC)
Quote
ima_losin

Rank: Member

Groups: Registered
Joined: 8/15/2020(UTC)
Posts: 0
United States
Location: NJ

For me, the issue was corrosion on the little metal disk at the top of the igniter, above the ceramic. I used a piece of 320 grit sandpaper and brought the disk from a very dark gray color to a very light 'bare metal' color. Note that I sanded the top, sides and bottom of the metal disk. To get to the bottom of the metal disk, I very gently pulled up on it so I could slip the sandpaper between the ceramic and the metal disk, then pulled the sandpaper back and forth.

On a side note, cleaning sprays and my kids boiling over their pasta seem to be the main causes of this issue!

P.S. sorry for reviving a 3yr old thread, but figured this will be helpful to anyone looking up the issue.
Guest  
#9 Posted : Monday, April 5, 2021 9:07:33 PM(UTC)
Quote
Guest

Rank: Guest

Groups: Registered
Joined: 8/10/2018(UTC)
Posts: 0
United States
Location: 99556

Was thanked: 1 time(s) in 1 post(s)
What if it clicks only on low?
Guest  
#10 Posted : Wednesday, May 26, 2021 10:58:20 AM(UTC)
Quote
Guest

Rank: Guest

Groups: Registered
Joined: 8/10/2018(UTC)
Posts: 0
United States
Location: 99556

Was thanked: 1 time(s) in 1 post(s)
I have the same issue. Clicks only on low ... so annoying!
Any ideas would be welcomed!

Quick Reply Show Quick Reply
Users browsing this topic
2 Pages12>
New Topic Post Reply
Forum Jump  
You can post new topics in this forum.
You can reply to topics in this forum.
You can delete your posts in this forum.
You can edit your posts in this forum.
You cannot create polls in this forum.
You can vote in polls in this forum.