Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
blackwidow71  
#1 Posted : Sunday, June 19, 2011 3:02:24 PM(UTC)
blackwidow71

Rank: Member

Groups: Registered
Joined: 6/19/2011(UTC)
Posts: 2

I turned my oven on tonight to preheat for lasagna and shortly thereafter it started beeping and an F10 error code was displaying. I noticed that the broil element was on but not the bottom element. When it cooled down I turned it back on to try again and same thing....it was on Bake but only the broil element was working and the F10 error appeared again. Any ideas on what this may be??? Money is really tight right now and we cannot afford a repairman or a new stove! :confused:
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
IndyMatt  
#2 Posted : Saturday, July 23, 2011 11:25:30 AM(UTC)
IndyMatt

Rank: Member

Groups: Registered
Joined: 7/23/2011(UTC)
Posts: 1

Did you resolve your problem?
blackwidow71  
#3 Posted : Wednesday, August 3, 2011 5:01:14 PM(UTC)
blackwidow71

Rank: Member

Groups: Registered
Joined: 6/19/2011(UTC)
Posts: 2

Yes, it is the clock/timer depending on your model number it ranges from $80-$100 for the part.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.