Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Storm Totten  
#1 Posted : Tuesday, July 27, 2010 3:06:12 PM(UTC)
Storm Totten

Rank: Member

Groups: Registered
Joined: 7/27/2010(UTC)
Posts: 2

I have a new 5701M680-60 CNTRL-ELEC (control board) I got from APP. It has three relays on circuit board and old one has two. New one has terminals marked BA,L1,BR,N(same as old one) plus L2 and DBL, which are not on old one.Parts person said this is the right one for this range. Can I assume it would work on more than one model and plug wires on to terminals as on old one? just wanted to make sure.
Also when I took it out of box I saw that three of the round capacitors(I think that is what they are?) There are two on the top left and two on top right.
They are bent over with two against each other and the third against a smaller one that is sodered in flat position on board. Should I attempt to be real gentle and straighten them up some so they do not touch. I though about heat transfer maybe? They are all vertical on the old board. Thank you very much for your time and consideration!
Storm Totten storm1941@gmail.com
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
Storm Totten  
#2 Posted : Thursday, August 5, 2010 10:44:45 PM(UTC)
Storm Totten

Rank: Member

Groups: Registered
Joined: 7/27/2010(UTC)
Posts: 2

I WIRED CIRCUIT BOARD AS PER OLD BOARD AND STRAIGHTENED CAPACITORS AND EVERY THING WORKS FINE. THANKS FOR OPPORTUNINTY TO POST. MY PROBLEM IS SOLVED Storm Totten
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.