Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

New Topic Post Reply
Options
Go to last post Go to first unread
Guest  
#1 Posted : Saturday, May 1, 2021 3:45:42 PM(UTC)
Quote
Guest

Rank: Guest

Groups: Registered
Joined: 8/10/2018(UTC)
Posts: 0
United States
Location: 99556

Dreyer runs and tub rotates, timer works, no heat.

Removed heater and tested the heating element at 5 ohms, from what I read here any continuity represents a good element.

Also tested both fuses and both have 0 ohm continuity. Test good.

Removed the high temp thermostat switch and it tested a 0 ohms. I couldn't find test procedures for it on site. If this unit is normally open and trips to closed then it is likely the culprit. If this switch is normally closed and fails open then I'm stumped at where to look for the problem.

Please help...

Edited by user Saturday, May 1, 2021 3:48:58 PM(UTC)  | Reason: Not specified

Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
Guest  
#2 Posted : Sunday, May 2, 2021 5:57:54 PM(UTC)
Quote
Guest

Rank: Guest

Groups: Registered
Joined: 8/10/2018(UTC)
Posts: 0
United States
Location: 99556

Also tested the centrifugal switch in the motor and it was good. Found testing procedures for the HT Thermostat and that tested good as well. UGH!!!
Quick Reply Show Quick Reply
Users browsing this topic
New Topic Post Reply
Forum Jump  
You can post new topics in this forum.
You can reply to topics in this forum.
You can delete your posts in this forum.
You can edit your posts in this forum.
You cannot create polls in this forum.
You can vote in polls in this forum.