Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
bburks  
#1 Posted : Wednesday, May 21, 2008 9:32:36 AM(UTC)
bburks

Rank: Member

Groups: Registered
Joined: 5/21/2008(UTC)
Posts: 1

I have a KUIS182JSS2 ice machine. The water valve opens and closes, the recirc pump runs, the freezer plate does not cool down. Ater running 2 hours the bin was warm and no ice. I would think the compressor system would be OK since it seems well made. However the circuit board seems to be in a vulnerable place for damage from humidity. Any idea where or how to start checking components?
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
ran007  
#2 Posted : Tuesday, July 8, 2008 7:23:47 PM(UTC)
ran007

Rank: Member

Groups: Registered
Joined: 6/29/2008(UTC)
Posts: 9

BBurks,
I'm having similar problems with my kitchenaid ice machine- did you get yours fixed? My compressor gets hot. I thought it was a relay module that connects to the compressor, but wasn't.

I'm curious if you had yours fixed.
thanks!
randall
ran007  
#3 Posted : Friday, February 13, 2009 4:51:20 AM(UTC)
ran007

Rank: Member

Groups: Registered
Joined: 6/29/2008(UTC)
Posts: 9

Thanks for the quick reply.

It turned out to be a shot compressor. Replaced it and it works great now.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.