Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

New Topic Post Reply
Options
Go to last post Go to first unread
Guest  
#1 Posted : Saturday, November 19, 2022 5:06:24 AM(UTC)
Quote
Guest

Rank: Guest

Groups: Registered
Joined: 8/10/2018(UTC)
Posts: 0
United States
Location: 99556

Was thanked: 3 time(s) in 3 post(s)
I’m writing from Germany after browsing and watching a lot of videos on Youtube. In Germany, I can’t find a resource for helpful troubleshooting suggestions, and I hope you can help me out: our 15 year old, true and trusted, everyday - in - use Kitchenaid Artisan 5KSM150 is giving me more and more troubles: the engine starts sometimes, sometimes not. If I screw out the carbons (still about 16 mm) and reinstall them, it will work for 3 - 4 starting attempts. If it runs, the engine won’t hold its speed (changing and / or decreasing speed) and starts to smell weird (without getting hot). From the middle and front end there are strange grinding noises. I replaced the worm gear 2020 (used original parts) and regreased the whole thing. I used your video to dial in the basic and 6th gear speed, and could see the governor working. What do you suggest / which parts should I replace?

Thanks a lot, very best regards from the Baltic sea and stay safe

Ralph

Edited by user Saturday, November 19, 2022 5:07:17 AM(UTC)  | Reason: spelling issues

Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
Quick Reply Show Quick Reply
Users browsing this topic
New Topic Post Reply
Forum Jump  
You can post new topics in this forum.
You can reply to topics in this forum.
You can delete your posts in this forum.
You can edit your posts in this forum.
You cannot create polls in this forum.
You can vote in polls in this forum.