Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

New Topic Post Reply
Options
Go to last post Go to first unread
casey9110  
#1 Posted : Thursday, January 13, 2022 1:31:33 PM(UTC)
Quote
casey9110

Rank: Member

Groups: Registered
Joined: 5/10/2021(UTC)
Posts: 0
United States
Location: Texas

Thanks: 1 times
GE dishwasher GDF540HGD2BB. Heater has stopped working. Heater itself measures 17 Ohms. Thermal Cut Off has continuity through it. I put the dishwasher into test mode, it shows no error codes. When I put it in test mode, heater test, there is no voltage at the board. Other test modes are testing good, recirculation pump, drain pump, water valve, soap dispenser test. Dishwasher will run each cycle just fine except that it can't heat the water mid cycle, and it doesn't dry the dishes at the end. A replacement main board operates the same. Did I get a defective replacement board, or does the test mode still rely on other auxiliary temperature sensors that are part of other circuits?
Thanks
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
casey9110  
#2 Posted : Thursday, January 13, 2022 2:33:57 PM(UTC)
Quote
casey9110

Rank: Member

Groups: Registered
Joined: 5/10/2021(UTC)
Posts: 0
United States
Location: Texas

Thanks: 1 times
Let me add in some more troubleshooting. I removed and tested the flood switch assembly. The flood switch circuit opens and closes when it goes from upside down and right side up. the Thermistor circuit started at 2.85 K Ohms and when placed in a cup of hot water went down to 2.4 K Ohms. I don't have the specific resistance values for temperature settings, but I would think this last component is also functioning properly. I don't know what else to test or replace at this point.
ohm  
#3 Posted : Friday, January 14, 2022 6:40:02 AM(UTC)
Quote
ohm

Rank: Member

Groups: Registered
Joined: 7/18/2017(UTC)
Posts: 102

Was thanked: 11 time(s) in 10 post(s)
Resistance Temperature
20K 50
11K 75
5.8K 100
3.4K 125
2.1K 150
1.3K 175
The way to test it is to disconnect the float switch harness, then see if it will heat in the test mode.

Edited by user Friday, January 14, 2022 6:42:35 AM(UTC)  | Reason: Not specified

thanks 1 user thanked ohm for this useful post.
casey9110 on 1/14/2022(UTC)
casey9110  
#4 Posted : Friday, January 14, 2022 10:49:15 AM(UTC)
Quote
casey9110

Rank: Member

Groups: Registered
Joined: 5/10/2021(UTC)
Posts: 0
United States
Location: Texas

Thanks: 1 times
Originally Posted by: ohm Go to Quoted Post



The way to test it is to disconnect the float switch harness, then see if it will heat in the test mode.



Wow! My hat is off and I bow down to you! * I've uninstalled this DW more times than I care to admit just to be stumped each time. With the correct Ohm / temp spec, that proved that the thermistor - although it reacts to temp change - is way out of spec. Obviously the DW thinks it's already quite hot so no need for the heater. The test mode pissed me off since it wasn't doing isolated tests, but when I disconnected the float switch and re did the heater test... 120 volts at the connector!
Time to order a float switch assembly! Thank you so much!
ohm  
#5 Posted : Friday, January 14, 2022 2:24:15 PM(UTC)
Quote
ohm

Rank: Member

Groups: Registered
Joined: 7/18/2017(UTC)
Posts: 102

Was thanked: 11 time(s) in 10 post(s)
Your welcome!
Quick Reply Show Quick Reply
Users browsing this topic
New Topic Post Reply
Forum Jump  
You can post new topics in this forum.
You can reply to topics in this forum.
You can delete your posts in this forum.
You can edit your posts in this forum.
You cannot create polls in this forum.
You can vote in polls in this forum.