Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
lorraineg57  
#1 Posted : Thursday, November 19, 2020 10:44:32 AM(UTC)
lorraineg57

Rank: Member

Groups: Registered
Joined: 11/19/2020(UTC)
Posts: 0
United States

I have a whirlpool wall oven. If I turn the oven temp up, I need to hit start again after I enter the temp I want to raise to. However, when I do that, the temp reading drops significantly, as if I'm starting the whole thing from cold. Tonight, I had something in the oven and wanted to brown it quickly on the top rack. I changed the temp from 425 to 450, hit the start button. Keep in mind that this oven has been at full temp of 425 for over half an hour. Look at the temp display and it says something like 255.....Whaaat??? How can it be 255 when it was 425 30 seconds ago? I've noticed this same thing when I've accidentally hit the wrong button and turned the oven off. It's on 375 or whatever and I accidentally hit the cancel button. Immediately turn it back on to the previous temp and it starts at 200 or something and says preheating again. Any ideas? It's only 4 years old.

Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.