Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.



New Topic Post Reply
Go to last post Go to first unread
#1 Posted : Friday, October 16, 2020 10:58:40 AM(UTC)

Rank: Member

Groups: Registered
Joined: 10/16/2020(UTC)
Posts: 0

So I feel like I have tested everything and have had no luck. The dryer works but does not heat. I was able to narrow it down to what I thought was the switch on the motor because when I would play around with it, I was able to get the heating element to heat up but then after a bit I was no longer able to. All my fuses are reading continuity and the element is reading 10.4ohms with power off. When I turn power on, It reads 119-120v. I checked the relay. With power off only one lead received 119.1 and with power on they both read 119.1. The fuses on the blower casing are also reading fine as well. I've even tried putting in new fuses and still no luck. I've taken apart the heating element to inspect the wires and they are all intact. Can someone point me in the right direction? Im wondering if I was sent a broken switch on the motor.

Edited by user Friday, October 16, 2020 11:55:32 AM(UTC)  | Reason: Not specified

See inside of your appliance - diagrams and part photos for virtually every model.

powered by
Quick Reply Show Quick Reply
Users browsing this topic
New Topic Post Reply
Forum Jump  
You can post new topics in this forum.
You can reply to topics in this forum.
You can delete your posts in this forum.
You can edit your posts in this forum.
You cannot create polls in this forum.
You can vote in polls in this forum.