Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
illfixanything  
#1 Posted : Monday, September 7, 2020 6:49:58 PM(UTC)
illfixanything

Rank: Member

Groups: Registered
Joined: 8/7/2015(UTC)
Posts: 1

Wolf Dual Fuel oven temp while in Bake mode set to 350, will rise to 350 and all the while the display switches back and forth from the set temperature (350) to the actual temp as it heats.
Once it reaches set temp red light goes out (no longer calling for heating element) and signal sounds to alert that temp was reached. This is what it should do.

But at that point raising the set temp to a higher temp, let's say 375, the red light goes on but the actual temp as measured by several oven thermometers, does not change and the temperature display no longer switches between the actual and set temps, only displays set temp. Eventually the red light goes out but the alert never sounds.
I have tested it in diagnostic mode and all elements test OK. There were no errors set.

Why doesn't oven reach a higher temperature? Why does the display no longer switch back and forth between set temp and actual temp?

Switching to convection, which relies upon two additional heating elements, works normally.

Any thoughts about cause? Bad element? Bad control board? Bad relay board? Has anyone worked n the Wolf electric oven?
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.