Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Drewmich  
#1 Posted : Thursday, May 7, 2020 6:19:37 PM(UTC)
Drewmich

Rank: Member

Groups: Registered
Joined: 5/7/2020(UTC)
Posts: 0
United States

We have the double GE Profile Dbl Oven w/ the PT970S MW on top. Installed it new in our kitchen in 2008 and literally have had no issues with the MW ... with daily use..

So this week I noticed a few things happening to the MW.

A - After running a MW cycle ... and cycle completes - the message starts to scroll that cycle is complete - the LCD display is now black ... but the lower oven LCD time is still good? After about 15-30 seconds -the MW LCD comes back on with the factory default 000000 and the LCD display needs it clock reset. I reset the clock and it is fine until the next use ... then it starts all over again ...

B - Seems like it might be related to the MW door somehow.

C - So today - the MW LCD display is DARK and nothing on it works - light - and function buttons etc.... won't reset.

D - I had ordered a replacement circuit and powered off the oven .... replaced the board carefully (I am an electrician and own an electronics repair business ... :) Still Dead after power back on!

So what is the next step?

Thanks for your help.


Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.