Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.



Go to last post Go to first unread
#1 Posted : Sunday, May 5, 2019 8:30:56 AM(UTC)

Rank: Member

Groups: Registered
Joined: 5/5/2019(UTC)
Posts: 0
United States

Hello, I have a GE GLD4260L00SS (QuietPower1) that suddenly does not want to start
There is power going to the control panel as I can see lights. However when I press any of the buttons, the options don't change. When I close the door it appears to latch properly and I can hear the beep confirming it.

I tried to reset the breaker. Tried to hold the Heated Dry button a few seconds, thinking it could be locked but I think this model doesn't have locking capabilities anyway.

I saw a few articles and videos online about the 2 door switches located near the latch. I followed directions on how to test them with a multimeter. I tested both switches and they appear to be working.

Is it worth it to order the switches anyway and replace them or does it mean I have to go ahead and replace the main board?
See inside of your appliance - diagrams and part photos for virtually every model.

powered by
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.