Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
viper1522  
#1 Posted : Thursday, November 8, 2018 7:50:22 AM(UTC)
viper1522

Rank: Member

Groups: Registered
Joined: 11/8/2018(UTC)
Posts: 0
United States

I have a Samsung RS261MDRS/XAA refrigerator. It stopped cooling (both freezer and refrigerator) and I noticed the compressor wasn't running. The board had an burnt odor so I suspected the board had failed, but wasn't certain. I called a local appliance tech and he confirmed the compressor was not running and that the compressor was not receiving voltage. He said the board needed to be replaced. I found a factory board and installed it. I turned everything back on and the compressor did start warming (before it wasn't). I let the fridge run over night and checked on it about 6-7 hours later. It is still warm inside. The condenser fan was running and I did clean the coils. I'm at another stop point here scratching my head. Any pointers? Appreciate the help.
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.