Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Jveen  
#1 Posted : Friday, May 11, 2018 1:07:11 AM(UTC)
Jveen

Rank: Member

Groups: Registered
Joined: 5/11/2018(UTC)
Posts: 1

I have a GE Arctica about ten years old. I replaced the motherboard two years ago. Recently, the refrigerator compartment stopped cooling. I've taken the damper assembly out and the damper was in the shut position which makes sense because the airflow was about non existent when it was running. The freezer is running slightly warm. I am trying to set it to zero, but it stays at 6 degrees. In fact, when I try to set the temp for either the freezer or the refrigerator compartment the readout just pops back to the current temp. Also, the turbo cool button does nothing-usually it will start a fan. The condenser fan chirps ever so slightly. So...I'm thinking thermostat/ thermistors, or motherboard. What else could control the damper? The coil fan seems strong and I don't think it is the defroster because there is so little build up. Thanks for any feedback.
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.