Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
kanderna  
#1 Posted : Saturday, March 24, 2018 12:58:57 PM(UTC)
kanderna

Rank: Member

Groups: Registered
Joined: 4/14/2014(UTC)
Posts: 4

Hi All,

Whirlpool gas double oven. Top oven works just fine.

Control for bottom seems "normal," however it just says "Preheating," and temp reads "LO," and remains that way. No heat at all from the bottom and everything in there remains cool to the touch. With the top, we can hear everything "fire up." No sound at all from the bottom.

What am I looking at here? Thanks in advance!
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
ThatGuy  
#2 Posted : Saturday, March 24, 2018 1:22:39 PM(UTC)
ThatGuy

Rank: Advanced Member

Groups: Expert
Joined: 7/27/2010(UTC)
Posts: 1,395

This oven uses glow bar igniters. Before the burner lights, the igniter gets almost yellow hot. You should be able to see it or the glow from it for a minute or more after you turn it on.

If you don't see it glowing its either burned out or its not getting any voltage.
kanderna  
#3 Posted : Saturday, March 24, 2018 1:35:28 PM(UTC)
kanderna

Rank: Member

Groups: Registered
Joined: 4/14/2014(UTC)
Posts: 4

Originally Posted by: ThatGuy Go to Quoted Post
This oven uses glow bar igniters. Before the burner lights, the igniter gets almost yellow hot. You should be able to see it or the glow from it for a minute or more after you turn it on.

If you don't see it glowing its either burned out or its not getting any voltage.


Excellent. I'll have to check it out when we get home. I should be able to look at the top one to see what I'm looking for, right?
kanderna  
#4 Posted : Saturday, March 24, 2018 2:54:47 PM(UTC)
kanderna

Rank: Member

Groups: Registered
Joined: 4/14/2014(UTC)
Posts: 4

Yep... no glow at all. Anyone know if I can perform the replacement without access to the back on this model? I see sometimes you can pull the wire harness through to unplug
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.