Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
corkee  
#1 Posted : Friday, February 9, 2018 6:16:21 PM(UTC)
corkee

Rank: Member

Groups: Registered
Joined: 2/9/2018(UTC)
Posts: 1

I have replaced the heating element, the bi-metal fuse, and the high limit thermostat. Several weeks ago I noticed dishes were not being cleaned and grease was building up in the dishwasher. Before that we used to open the dishwasher and the heat and steam was incredible. Dishes spotless and sanitized. Now it seems that despite changing those parts the dishwasher does not heat the water during the sani rinse or the longer wash cycles (which the operating model also promises will heat water). We have always turned on the hot water tap before starting a cycle.
At the end of a wash cycle the sani light is blinking...probably telling me that it did not sanitize the dishes. To check on the new heating element I used the plate warmer cycle and it works just fine. I also used a dishwasher cleaner with a wax plug and it barely released any cleaner because the wax never melted. Is this a control panel issue? :confused:
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.