Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
mbg  
#1 Posted : Wednesday, November 22, 2017 11:49:33 AM(UTC)
mbg

Rank: Member

Groups: Registered
Joined: 11/22/2017(UTC)
Posts: 2

Seems mostly with heavy loads but tub seems locked in place when it should be spinning. If I stop the wash mode and spin the dial back to spin it will spin fine. It's like something is applying the brake? Control panel issue?

I have replaced the clutch and coupling with Appliance Parts Pro parts. I also saw where a repairman suggested to apply car brake caliper grease to the brake drum. Still have the issue.

Any suggestions welcome.

Thanks,

Mike
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
mbg  
#2 Posted : Wednesday, November 22, 2017 3:08:15 PM(UTC)
mbg

Rank: Member

Groups: Registered
Joined: 11/22/2017(UTC)
Posts: 2

Thought I should add that without any clothes in it if I cycle to spin and start it I can hear a loud click like something engaging (think it's always done this?). Starts spinning then if I shut it off it stops in about one second.

Mike
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.