Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Mdutch  
#1 Posted : Friday, November 10, 2017 6:28:48 AM(UTC)
Mdutch

Rank: Member

Groups: Registered
Joined: 11/10/2017(UTC)
Posts: 1

I have done all the repair diagnostics with regards to the Thermostat and Defrost heater. The freezer runs continuously. I have pulled the panel off the inside and noticed that after running for 4 hours that the top 1/3 of the coils have frost while the lower half is clear. The defrost heater did not feel warm however the thermostat was allowing voltage to the heater. Both had continuity. Could this be the result of a small leak in the system ? Or am I not checking it right? Door switch and gasket all were fine. Thanks
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
ThatGuy  
#2 Posted : Friday, November 10, 2017 10:26:19 AM(UTC)
ThatGuy

Rank: Advanced Member

Groups: Expert
Joined: 7/27/2010(UTC)
Posts: 1,395

The coils should have a light coating of frost all the way down. It sounds like your sealed system isn't sealed anymore. Its usually very hard to find leaks and seal them, not to mention very expensive.
Users browsing this topic
Similar Topics
Freezer runs continuously (Refrigerator & Freezer Repair)
by Rich West 11/14/2011 12:36:48 PM(UTC)
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.