Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
nagrath  
#1 Posted : Wednesday, October 12, 2016 6:47:41 PM(UTC)
nagrath

Rank: Member

Groups: Registered
Joined: 4/19/2011(UTC)
Posts: 8

Hi All,
I was using my GE microwave and it suddenly stopped during cooking. The display asked me to set the time. I did, and hit "+30 sec" and the timer clicked on for a second, then went dark. To get the display to respond at all, I had to open then shut the door again. time cook, defrost, almost all modes do the same thing - start then click off. I thought perhaps it was the magnetron until I discovered that popcorn mode works fine, heats, runs a full cycle, etc. Does this point to the keypad or the control board? Also, I cannot figure out how to get inside the front door to even get at the keypad. There are no screws front, back, top, or bottom that I can see, except those holding the handle. Oh, it also randomly makes a quiet "beep" every once in a while without being touched. I am thinking it may be the touch[ad but do not know how to troubleshoot further. Thanks!
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
nagrath  
#2 Posted : Friday, October 14, 2016 8:57:33 PM(UTC)
nagrath

Rank: Member

Groups: Registered
Joined: 4/19/2011(UTC)
Posts: 8

So a day and a half later, I try the microwave, it acts the same as above. 12 hours after that, it works fine. 12 hours after that, back to not working! Frustrated, I figure out how to open up the door, and I clean the ribbon cable connection to the keypad, and put it all back together. It works! For now. Is it really the keypad? It doesn't even look like the keypad is available any more? At least not here?
millechick  
#3 Posted : Monday, October 17, 2016 3:03:59 PM(UTC)
millechick

Rank: Member

Groups: Registered
Joined: 10/17/2016(UTC)
Posts: 1

I came here looking for answers to a similar problem. I'll try your fix, if I can figure it out. I think my 3 year old microwave is possessed! It has, twice, turned it's fan on. If I hit Micro Express, it turns on for a second, then goes into pause mode on it's own. The clear/stop button does nothing. I have to open the door and close it again to get it to stop. Sometimes it works, others not. The popcorn button is hit and miss. It's the craziest thing. I've tried unplugging it for 30 minutes to reset it, but that didn't work.

My model is the GE Profile 1.7 cu ft Over-the-range Convection Microwave, model #PVM1790SRSS. We had one at our old house for years and loved it. I'm going to bummed if I have to replace a $600 microwave after only three years!


Originally Posted by: nagrath Go to Quoted Post
So a day and a half later, I try the microwave, it acts the same as above. 12 hours after that, it works fine. 12 hours after that, back to not working! Frustrated, I figure out how to open up the door, and I clean the ribbon cable connection to the keypad, and put it all back together. It works! For now. Is it really the keypad? It doesn't even look like the keypad is available any more? At least not here?
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.