Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Studog  
#1 Posted : Friday, March 18, 2016 2:02:59 PM(UTC)
Studog

Rank: Member

Groups: Registered
Joined: 3/18/2016(UTC)
Posts: 1

I have an over the range kenmore that is right around 5 yrs old. It runs like normal and sounds normal but will not heat anything. I read online it could be a diode, door switch or magnetron. I also called a local appliance repair shop and he basically said he don't need to come out, he knows its the magnetron cuz its a kenmore made by samsung and its made cheap. It was probably $3-400 brand new so i don't want to replace if i don't have to. Any thoughts?

I was also looking at getting some sort of warranty protection that covers appliances but I'm not sure it would cover this? And if it did, would they be able to tell it has been broke for some time? Not sure they would cover it if they could tell it was broke before the warranty began.

Any help would be greatly appreciated.
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
Users browsing this topic
Similar Topics
Kitchenaid microwave runs but won't heat (Microwave Repair)
by ladymay65 3/27/2009 10:41:48 PM(UTC)
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.