Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
billchapjr  
#1 Posted : Wednesday, November 18, 2015 7:28:07 PM(UTC)
billchapjr

Rank: Member

Groups: Registered
Joined: 7/18/2013(UTC)
Posts: 9

I'm working on a Samsung Range Convection oven. Model FTQ387LWGX/XAA. Customer complaint was that oven taking to long to preheat, and Broiler not working. The broiler element is ok and the oven sensor checks out ok has correct resistance.
Main control board seems to be working it cycles the elements from top to bottom but no power to broiler element. I have power to on leg but not to other. I checked for proper voltage at the Sub PCB oven control board.
I replaced the board and the sensor. Buy the way I never got lock indicator and any error codes and all the motors are operating.
After replacing the board I got an E28 error code which said open sensor, also got a code EOE which is the door lock control and none of the motors worked.
so I reinstalled the old board and everything worked like before except no broiler element power.
I think I have a bad Sub PCB board that I ordered. I dont think the main board is the problem. Am I right or does any one think its something else.
I appreciate any help on this.
Bill
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.