Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
zooeyhall  
#1 Posted : Saturday, November 7, 2015 5:28:16 PM(UTC)
zooeyhall

Rank: Member

Groups: Registered
Joined: 12/9/2009(UTC)
Posts: 6

I have a Kenmore electric range where the clock will not stay on. If I press the clock set button it lights up but then goes off again in 5 seconds. It continues to keep the correct time.


I researched the Internet, and some have advised holding the clock set button for 15 seconds to reset it. Tried this and it didn't help. I also turned off the power for a day to see if that might reset.


This display issue seems to have started about the same time I had a power outage. Can anyone advise on how to get this display to stay on? I hate to have to buy a new clock board because they cost over $200. Thanks for any advice!
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
denman  
#2 Posted : Sunday, November 8, 2015 2:19:38 AM(UTC)
denman

Rank: Advanced Member

Groups: Senior Expert
Joined: 2/29/2008(UTC)
Posts: 19,638

Was thanked: 10 time(s) in 10 post(s)
Sorry to be the bearer of bad news but it does sound like a bad control board.

You may want to purchase it from AppliancePartsPros as they will let you return the part if it does not fix your problem. Please see their return policy.

Click on the picture for more info on the part.
Part number: AP3586251
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.