Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Crafter_Man  
#1 Posted : Monday, October 12, 2015 4:30:35 AM(UTC)
Crafter_Man

Rank: Member

Groups: Registered
Joined: 10/12/2015(UTC)
Posts: 2

We have a Kitchen Aid KDFE104DBL dishwasher. It's only 1 year old.

It's worked well up until a week ago. But now it won't drain the water from the tub. I checked for a blockage in the drain hose, and there is no blockage. I also cleaned both filters.

When you press the “drain” button, the drain motor/pump produces an audible hum, and you can feel a slight vibration when you touch the drain motor/pump with your fingers. But it won't pump out the water.

Any suggestions?
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
Crafter_Man  
#2 Posted : Saturday, October 17, 2015 9:29:56 AM(UTC)
Crafter_Man

Rank: Member

Groups: Registered
Joined: 10/12/2015(UTC)
Posts: 2

It's fixed! :)

I first went out and bought a new drain pump (part number W10348269) for $70. I was able to remove the old drain pump without taking the dishwasher out of the cabinet, and it's a pretty simple job. When I removed the old pump, I noticed there was a piece of plastic debris in there!

So the old drain pump was O.K. - a piece of plastic debris was keeping the impeller from turning.

I went ahead and installed the new pump anyway. (Unfortunately there is a "no return" policy at the Appliance Parts Store.)

So... for anyone having the same symptoms with their dishwasher, remove the drain pump and look for foreign debris in there BEFORE going out and buying a new pump.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.