Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
tartrazine  
#1 Posted : Tuesday, September 1, 2015 12:54:46 AM(UTC)
tartrazine

Rank: Member

Groups: Registered
Joined: 4/27/2011(UTC)
Posts: 3

I have a carrier 8SSC075-111GC furnace with a blower that stopped blowing. Instead when the furnace tries to turn the blower on, it hums, and moves VERY slowly. Then after a couple minutes it quits and tries again in a while. I can turn it by hand, but with some resistance. I left it off for a couple days, then tried it again and it came on for a couple hours before dying again.

I replaced the capacitor that was on the front of the blower assembly, since that was a cheap thing to try. It did turn on again after I put the new capacitor in (it had been off for a couple days again), then died again after a few hours.

Is that the only (start?) capacitor? Or is there another (run?) capacitor that could be bad? Or is it the motor?

If it's the motor, do I need to put in a new OEM part, or is there a "universal" replacement I could get by with? This thing is already 23 years old, so it doesn't have to last forever.

I'd really appreciate any help. Thanks.
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.