Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.



Go to last post Go to first unread
#1 Posted : Monday, February 3, 2014 1:45:15 PM(UTC)

Rank: Member

Groups: Registered
Joined: 2/3/2014(UTC)
Posts: 1

I have a gas log fireplace with a switch on the wall that ignites the fire from a pilot light. The problem is, if I want to use my blower, I have to plug the blower into a metal box receptacle located in the service area under the fireplace, and then unplug it to shut in off. Since this wasn't very handy, I ran a 14-2 romex wire from the receptacle box to the flame switch box and wired it as an extension of the black wire to switch the blower on and off. I used a duplex switch so that I didn't have to change out the wall box to accommodate 2 separate switches. I think this is where I screwed up. I first tried the top switch for the flame. It started up and went out as it should. I turned on the bottom switch for the blower and it also started up and shut down as it should. But when I turned them on together, there was a small flash of fire and then nothing. The blower continued to run but the fire would not start.

Since the duplex shares a ground with both switches, could this have caused the problem? Also, I'm not sure what I now need to replace.

Thanks for your help!
See inside of your appliance - diagrams and part photos for virtually every model.

powered by
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.