Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Vicki Brown  
#1 Posted : Wednesday, October 2, 2013 4:23:45 PM(UTC)
Vicki Brown

Rank: Member

Groups: Registered
Joined: 10/2/2013(UTC)
Posts: 6

My oven broiler on top works fine but bottom element will not heat up,element is good.We looked things over and think it might be a relay but can not find the part anywhere,went to a service place and they still have not called us back.It is a little relay with five prongs on it,any suggestions on what it could be or where this part can be bought would be great
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
HumboldtRepairMan  
#2 Posted : Wednesday, October 2, 2013 4:37:26 PM(UTC)
HumboldtRepairMan

Rank: Member

Groups: Registered
Joined: 7/16/2013(UTC)
Posts: 916

Do you have 120v going to the element when you turn it on?
Vicki Brown  
#3 Posted : Wednesday, October 2, 2013 4:38:44 PM(UTC)
Vicki Brown

Rank: Member

Groups: Registered
Joined: 10/2/2013(UTC)
Posts: 6

Originally Posted by: HumboldtRepairMan Go to Quoted Post
Do you have 120v going to the element when you turn it on?

On one side
Vicki Brown  
#4 Posted : Wednesday, October 2, 2013 4:40:42 PM(UTC)
Vicki Brown

Rank: Member

Groups: Registered
Joined: 10/2/2013(UTC)
Posts: 6

Originally Posted by: Vicki Brown Go to Quoted Post
On one side

The small relay is connected to some of the wires to the burner
HumboldtRepairMan  
#5 Posted : Wednesday, October 2, 2013 4:43:55 PM(UTC)
HumboldtRepairMan

Rank: Member

Groups: Registered
Joined: 7/16/2013(UTC)
Posts: 916

I'm not talking about relays.....whats your voltage leading to your bottom element from hot to neutral
Vicki Brown  
#6 Posted : Wednesday, October 2, 2013 4:47:58 PM(UTC)
Vicki Brown

Rank: Member

Groups: Registered
Joined: 10/2/2013(UTC)
Posts: 6

Originally Posted by: HumboldtRepairMan Go to Quoted Post
I'm not talking about relays.....whats your voltage leading to your bottom element from hot to neutral All we know is there is full power going to only one side of the element
HumboldtRepairMan  
#7 Posted : Wednesday, October 2, 2013 4:51:02 PM(UTC)
HumboldtRepairMan

Rank: Member

Groups: Registered
Joined: 7/16/2013(UTC)
Posts: 916

Watch a couple video's so you can figure it out. We're volunteers here so we don't give out advise without the person knowing how to do proper testing with voltmeters and that are mechanically inclined to figure most things out.
electric oven not heating - YouTube
Vicki Brown  
#8 Posted : Wednesday, October 2, 2013 4:59:51 PM(UTC)
Vicki Brown

Rank: Member

Groups: Registered
Joined: 10/2/2013(UTC)
Posts: 6

Originally Posted by: HumboldtRepairMan Go to Quoted Post
Watch a couple video's so you can figure it out. We're volunteers here so we don't give out advise without the person knowing how to do proper testing with voltmeters and that are mechanically inclined to figure most things out.
electric oven not heating - YouTube

My father tested and looked everything over and the relay looks like it is tripped to him,when he tested he had said power is only going to one side of element,the repair shop we went to thinks it is this part also but when he brings up the parts page this part does not come up,he thought they replaced this part with a new kit but he could not find any info,so we have been waiting for a call for a week,the service place is 2 hrs away,so I thought I would try on here
HumboldtRepairMan  
#9 Posted : Wednesday, October 2, 2013 5:04:38 PM(UTC)
HumboldtRepairMan

Rank: Member

Groups: Registered
Joined: 7/16/2013(UTC)
Posts: 916

Typically you can't buy single relays by themselves you have to replace the whole board the relay is associated with that's why they don't show up on the schematics and i still have no clue what board your finding that relay on. Most likely it's the main board he's talking about and you have to replace the whole board that's faulty.
Vicki Brown  
#10 Posted : Thursday, October 3, 2013 4:26:11 PM(UTC)
Vicki Brown

Rank: Member

Groups: Registered
Joined: 10/2/2013(UTC)
Posts: 6

Finally found the relay I was looking for 318112701,It is a single unit.Thank you for all the help
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.