Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
scwalker  
#1 Posted : Monday, April 22, 2013 10:24:15 AM(UTC)
scwalker

Rank: Member

Groups: Registered
Joined: 4/22/2013(UTC)
Posts: 1

I have a Whirlpool Accubake Super Capacity 465 that wil sometimes not heat up or maintain temp. the problem is sporadic. Any Ideas?
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
scott5495  
#2 Posted : Monday, April 22, 2013 3:21:55 PM(UTC)
scott5495

Rank: Member

Groups: Registered
Joined: 4/19/2013(UTC)
Posts: 188

the glow bar next to you burner could be bad. the bar can still glow even if it is bad. the bar has to pull at least 3 amps to open the gas valve. the bar can have a crack too small to see. if you have an amp meter, clip the meter around one wire and turn on to read amps. careful, this could be one of those times it ignites. the other possible problem could be the thermistor [ oven thermostat] or the relay on the control board. check the back of the control board for a bad solder joint. if burned or cracked resolder.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.