Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
mgray5808  
#1 Posted : Wednesday, February 13, 2013 8:40:14 PM(UTC)
mgray5808

Rank: Member

Groups: Registered
Joined: 2/13/2013(UTC)
Posts: 3

On my Ge top load when filling it overflows if I unplug it from the wall it stops. I took off the tube that goes to the switch and cleaned it out.still overflows I then blew in to tube and it shuts off .question is the square box on tub that tube connects to is it supposed to have water in it. Any ideas what might be going on ?
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
fairbank56  
#2 Posted : Thursday, February 14, 2013 5:14:41 AM(UTC)
fairbank56

Rank: Advanced Member

Groups: Expert
Joined: 10/16/2012(UTC)
Posts: 3,806

The box does get some water in it when the tub is filling but once the water level goes above the box level it shouldn't get much more water in it. Use a turkey baster with hot water to flush out the box as best you can. Check the hose for any cracks/splits/kinks all the way up to the switch behind the control panel. Replace the hose and/or switch if necessary.

Eric
mgray5808  
#3 Posted : Thursday, February 14, 2013 7:08:18 PM(UTC)
mgray5808

Rank: Member

Groups: Registered
Joined: 2/13/2013(UTC)
Posts: 3

Thanks I will give it a try
mgray5808  
#4 Posted : Monday, February 18, 2013 5:21:53 PM(UTC)
mgray5808

Rank: Member

Groups: Registered
Joined: 2/13/2013(UTC)
Posts: 3

Thank you I replaced the hose and it seems to be working.:)
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.