Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
richardls  
#1 Posted : Sunday, December 9, 2012 7:51:38 PM(UTC)
richardls

Rank: Member

Groups: Registered
Joined: 12/9/2012(UTC)
Posts: 1

I have a GE Hood over an island with a stove. It doesn't power on, but the transformer is getting in 120v and putting out 12v. Any idea why nothing turns on when I press buttons (no ligts or fan) and how I can fix it?

Also, unable to find service manual if anyone has one they can e-mail me I'd greatly appreciate it.

Thank you in advance for your help.

-Richard
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
Gene  
#2 Posted : Monday, December 10, 2012 6:39:50 PM(UTC)
Gene

Rank: Advanced Member

Groups: Senior Expert
Joined: 7/19/2007(UTC)
Posts: 27,455

Hi Richard,

Perform the troubleshooting as described in the attached mini-manual and post the results.

Here are the breakdown diagram and Range Hood parts for GE ZV850SB2SS - AppliancePartsPros.com

Gene.
File Attachment(s):
31-20753-1 - ZV850SB2SS - mimi-manual.pdf (539kb) downloaded 18 time(s).

You cannot view/download attachments. Try to login or register.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.