Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Dan Adler  
#1 Posted : Thursday, July 12, 2012 11:37:17 AM(UTC)
Dan Adler

Rank: Member

Groups: Registered
Joined: 7/12/2012(UTC)
Posts: 2

Fridge is working fine but freezer won't get below zero. I changed the thermostat and the defrost timer. Still no improvement. The condenser fan works (lots of air from under the unit). Any suggestions?
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
Simon / APP Team  
#2 Posted : Thursday, July 12, 2012 11:56:04 AM(UTC)
Simon / APP Team

Rank: Advanced Member

Groups: APP Team
Joined: 2/12/2012(UTC)
Posts: 5,556

Hi.

First -check if the condenser is clean- if not clean it really well.
Allow some time for the temperature to settle before checking it.
Next - open the evaporator and check how the coils are covered with frost.

Thank you. Post the results.

Simon.
Dan Adler  
#3 Posted : Friday, July 13, 2012 12:27:07 PM(UTC)
Dan Adler

Rank: Member

Groups: Registered
Joined: 7/12/2012(UTC)
Posts: 2

Already cleaned underneath. almost no frost on coils. It is 24 years old so...perhaps it has had it.
Simon / APP Team  
#4 Posted : Friday, July 13, 2012 12:55:12 PM(UTC)
Simon / APP Team

Rank: Advanced Member

Groups: APP Team
Joined: 2/12/2012(UTC)
Posts: 5,556

Hi.

This is the sealed system problem. $$$.

Simon.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.