Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
hornblower  
#1 Posted : Thursday, July 16, 2009 4:57:59 AM(UTC)
hornblower

Rank: Member

Groups: Registered
Joined: 7/16/2009(UTC)
Posts: 2

We had a power surge and outage the other night. The next morning I discovered the microwave display showed a "door" message when I tried to use it. I suspect one or both door switches are bad. How do I access these switches to check and possibly replace them? Thanks!
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
hornblower  
#2 Posted : Friday, July 17, 2009 9:29:40 AM(UTC)
hornblower

Rank: Member

Groups: Registered
Joined: 7/16/2009(UTC)
Posts: 2

Originally Posted by: MicrowaveDisplaycom Go to Quoted Post
I meant to say "same effect IF the magnetron's T.O.D." instead of "same effect IN the magnetron's T.O.D.".


Thanks for this information. I will look at it all and evaluate whether I want to tackle this job or not. I appreciate your help.
diydumbass  
#3 Posted : Friday, May 19, 2017 3:33:24 PM(UTC)
diydumbass

Rank: Member

Groups: Registered
Joined: 5/19/2017(UTC)
Posts: 1

I have nearly the same unit with exactly the same problem. Did you ever find the problem?
Initially the microwave magnatron failed and the light bulb had burned out a while back, so I figured I would tackle the job myself. I had no issues replacing the bulb, magnatron and the diode. The light now worked and the magnatron was running but only for a few seconds. It stopped and displayed the error "door" on the display and the bulb was not illuminating when the door opened. Turns out the larger 20amp fuse had failed that is located on the top of the unit. Replaced that fuse then started the microwave again. Same result except this time it was the smaller 20amp fuse located in the microwave door circuit.
I am looking for some guidance before I continue? I have tested/metered all the 2 upper door switches, the capacitor, and the transformer. All the parts tested are in working order?
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.