Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
bschless  
#1 Posted : Wednesday, August 17, 2011 12:42:23 PM(UTC)
bschless

Rank: Member

Groups: Registered
Joined: 10/17/2010(UTC)
Posts: 3

Hi..I came back from vacation to my rent house and found a note from the renter...the dryer died. It's about 8 years old, a Kenmore mod 110 62042100.
There are literally no lights on the board and the machine appears to be DOA. I checked the 220 and there is power. Iran a voltmeter on pins 2 and 5 of P1 and there is power. I attempted to activate the diagnostic mode and it would not activate. Nothing lights up on the control panel at all. I checked P3 and P4 to make sure they were well seated. They were. I placed the negatyive lead on the P4-1 contact and then checked the other contacts. I get no reading on the voltmeter. Question...do I need to replace the electronic control unit? It's expensive, $165 and I don't want to replace it needlessly. The dryer has had very little use (maybe 5-10 times per year) due to water restrictions. Any suggestions?
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
Gene  
#2 Posted : Wednesday, August 17, 2011 2:33:15 PM(UTC)
Gene

Rank: Advanced Member

Groups: Senior Expert
Joined: 7/19/2007(UTC)
Posts: 27,455

Very likely the problem is a bad control board.

- The control board Part number: AP3841286
Part number: AP3841286



Gene.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.