Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
russff  
#1 Posted : Tuesday, June 7, 2011 8:48:09 AM(UTC)
russff

Rank: Member

Groups: Registered
Joined: 6/7/2011(UTC)
Posts: 1

I have a Kitchenaid KSRA25ILSS03 side by side refrigerator. The overload failed on the compressor and the thing thawed for almost 2 days, all the ice melted. Replaced the overload and it works fine again. The ice maker is working fine, it fills the bucket with cubes, but the dispenser doesn't work right. When I push the ice dispense button, I hear the motor work (but it doesn't sound as loud as it did before the thaw) and I see the auger turning, but it seems so weak that when an ice cube gets into the dispenser channel, the auger blades hit the cube and stop turning (but the motor is still working), like it doesn't have the oomph to push the cube out. The ice crusher does the same thing, I hear the crusher working, but no ice comes out. If I look from the inside when I push the dispense button, the door opens and the path is clear, so there is no blockage. The water dispenser works fine. I am thinking water may have gotten into the motor during the thaw (I pushed the ice dispenser while it was thawing and got a gush of water). Could it be something else?
Does anyone have the service manual for this model so I can figure out how to get the motor out?
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
ddsflagday  
#2 Posted : Wednesday, August 24, 2011 6:23:37 PM(UTC)
ddsflagday

Rank: Member

Groups: Registered
Joined: 8/24/2011(UTC)
Posts: 3

Our kitchenaid is doing the same thing, although we did not have any kind of overload problem. I can hear the motor working but it does not turn the augur at all. Were you able to solve your problem? If so, what did you do?
Thanks.


Originally Posted by: russff Go to Quoted Post
I have a Kitchenaid KSRA25ILSS03 side by side refrigerator. The overload failed on the compressor and the thing thawed for almost 2 days, all the ice melted. Replaced the overload and it works fine again. The ice maker is working fine, it fills the bucket with cubes, but the dispenser doesn't work right. When I push the ice dispense button, I hear the motor work (but it doesn't sound as loud as it did before the thaw) and I see the auger turning, but it seems so weak that when an ice cube gets into the dispenser channel, the auger blades hit the cube and stop turning (but the motor is still working), like it doesn't have the oomph to push the cube out. The ice crusher does the same thing, I hear the crusher working, but no ice comes out. If I look from the inside when I push the dispense button, the door opens and the path is clear, so there is no blockage. The water dispenser works fine. I am thinking water may have gotten into the motor during the thaw (I pushed the ice dispenser while it was thawing and got a gush of water). Could it be something else?
Does anyone have the service manual for this model so I can figure out how to get the motor out?
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.