Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
mickey  
#1 Posted : Saturday, October 27, 2007 7:29:57 AM(UTC)
mickey

Rank: Member

Groups: Registered
Joined: 9/26/2007(UTC)
Posts: 3

Hi, I got such great help from this site with my fridge I thought I'd try to see what might be wrong with my water softener before I call for service. First I should tell you I have no idea how a softener works, I just know how I feel when it doesn't. There is plenty of salt in that tank but no water, I used to see water at the bottom of that tank when the salt ran low. It is still cycling through and discharging a bunch of water but my water is NOT soft and it stinks!
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
fixxit  
#2 Posted : Saturday, October 27, 2007 11:36:44 AM(UTC)
fixxit

Rank: Advanced Member

Groups: Senior Expert
Joined: 10/25/2007(UTC)
Posts: 68

would be a bit easier with a modle # which is under the lid, but, Here goes. the first this to do would be to put the softener into by-pass, this is done at the back of the softener. its a push pull set up if it a relativly new. if older it is usualy a set of valves. next check the venturi. this is located under the cap behind the lid. it is usualy located to the left of the main valve body. unscrew the cap and look for sand, rust ect.. the ventury has a break down usualy on the underside of the cover to the salt tank. as you pull it appart watch the way everythig goes. a flipped seal or flow control plug can make this fail to work properly. the venturi breaks apart in this order, Top screen, top o-ring retainer ring and o-ring, flow control plug plate with flow control plug ( note plate has center stem and the stem goes up. flow control plug, this is directional as well, concave side down) check the flow control plug for sand or grit blocking it in the center. pull the flow control plate and check the seal under it. look for cracks or any gumm. your particular modle may have a secondary flow control plug under the seal check this one for clogging or being flipped as well (concave down). i have found a kitchen sink (with strainer in to pervent loosing any small parts down the drain) the best cleaning area. put every thing back in as they cam out, put the by-pass valve back out of bypass mode. and run a manual cycle by pressing the recharge/regen button and holding it untill it begins to cycle. you can manualy advance the cycles and if you have any leaks, use the bypass.
good luck and let us know if this fixes your problem
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.