Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
SaveSomeGreen  
#1 Posted : Friday, February 25, 2011 10:10:26 AM(UTC)
SaveSomeGreen

Rank: Member

Groups: Registered
Joined: 2/25/2011(UTC)
Posts: 1

Hi there I have an AprilAire humidifier 560 which is not getting the water. The connections are like below.

- 2 wires coming from transformer on the furnace
- 2 wire coming from the solonoid valve
- 2 wires coming from the Humidistat

- Out of 2 wires from furnace (24 V Ac), 1 connected to Solonoied and 1 to Humidistat. The other wire from Humidtstat is connected to Solonoid valve.

- I bought the multimeter to check the voltage but did not use it, if this helps.

- I removed the water connection to see if there is water coming just before the solenoid connection, and yes there is water just before the solenoid.

I tried calling many HVAC people which are asking to change the humidifier or asking to charge a way high fees for the "Service Call". No one is ready to give me an estimate first before repair.

Any help is highly appreciated.

- Nick
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.