Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Friar Dryer  
#1 Posted : Thursday, December 4, 2008 10:31:27 AM(UTC)
Friar Dryer

Rank: Member

Groups: Registered
Joined: 12/4/2008(UTC)
Posts: 2

So, here's my problem. If it makes any difference, it started right after I moved the dryer to replace the belt. The belt replacement went well, but the dyer started to not heat. For a while, it would work intermittently, and sometimes the flame would get going nice and blue.

I replaced the gas valve coils - an older assembly with a bunch of wires, O-rings, and wires going to the flame sensor and igniter.

This seems to have done no good.

The igniter glows, I hear a click, but no blue flame. It continues to cycle this way every minute or so. Igniter buzzes, click, no flame.

How would I know if I had a bad gas valve? Or possible a faulty part?

Thanks!
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
Gene  
#2 Posted : Friday, December 5, 2008 12:53:22 PM(UTC)
Gene

Rank: Advanced Member

Groups: Senior Expert
Joined: 7/19/2007(UTC)
Posts: 27,455

Check if the gas shut-off valve (next to the gas valve) is open.

If you installed the new coils according to the installation instructions, then the problem is a bad gas valve.

- The part number for the gas valve is AP2043417

Gene.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.