Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
neene  
#1 Posted : Sunday, November 16, 2008 7:17:59 AM(UTC)
neene

Rank: Member

Groups: Registered
Joined: 11/16/2008(UTC)
Posts: 2

This morning I cleaned around the burners of my thermador cooktop with water & bartenders friend. When I finished, I lit all the burners, some were burning funny so I decided to let them burn through the problem but wanted to do it a few at a time. When I went back to the front left burner (has low simmer) it wouldn't light, all the rest were working fine. I ran through them all again and now the back left (also low simmer) doesn't light either, like the front, it just clicks. The cooktop was bought about a year ago, not installed until 6 months ago and has had fairly light use. Thanks
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
Gene  
#2 Posted : Sunday, November 16, 2008 6:55:35 PM(UTC)
Gene

Rank: Advanced Member

Groups: Senior Expert
Joined: 7/19/2007(UTC)
Posts: 27,455

Sounds like the problem is a bad potentiometers and/or a simmer control, but if it is less than a year old, call Thermador for warranty service and do not attempt any repair. The model number you posted does not come up.

Gene.
neene  
#3 Posted : Tuesday, November 18, 2008 4:28:29 AM(UTC)
neene

Rank: Member

Groups: Registered
Joined: 11/16/2008(UTC)
Posts: 2

thanks so much for your advice
n/
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.