Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
gpallen  
#1 Posted : Sunday, December 5, 2010 4:23:08 AM(UTC)
gpallen

Rank: Member

Groups: Registered
Joined: 4/8/2010(UTC)
Posts: 8

The display panel in my GE Advantium microwave SCA1001KSS 02 went out. Everything still works but you can't see what you are you are entering, time, etc. Believe it will be either the KEY PCB Board WB27X10775 or the Smart Board WB27X10777. Don't won"t to order the wrong part since one is around $140 and the other is around $200. Any suggestions or way to check which one is bad.
thanks
gpallen
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
gpallen  
#2 Posted : Monday, December 6, 2010 4:27:34 AM(UTC)
gpallen

Rank: Member

Groups: Registered
Joined: 4/8/2010(UTC)
Posts: 8

Originally Posted by: MicrowaveDisplaycom Go to Quoted Post
The display is located on the KEY PCB Board WB27X10775 but it is run by the circuitry on the smart board.

So unless the display's been physically broken, it will require troubleshooting to determine where the problem lies. It may be as simple as a bad connection.

We have the full service manual for this oven and have uploaded it to our site here for your convenience.

Also at our Web site, we have a video available showing how to remove a typical over the range control panel assembly in under 5 minutes.


The service manual is great. Still have one question. It shows to test the board by connecting the various terminals on CN3 and CN4 and the press the appropriate key on the keypad. I haven't pulled the unit out yet to do any testing, but everything appears to work except the dispaly. Hopefully it will be a loose connection. The fan works, the light works, we are using the quick start button so we can still use the microwave, can spin the big round timer know to add or delete time to the 30 seconds it starts with, etc. The bottom portion of the display panel has a little pitcture of a microwave, (then these words beside it) FAN, REM, NITE, MUTE, TIMER. When I start the microwave, the picture of the microwave lights up indicating the unit is running, when I turn the fan on, FAN lights, push the set reminder button, REM lights up, push the timer button, TIMER lights up, etc. The upper part of the display which displays the clock, the time set and left to run, various setting to choose from, etc. is the part that is not working. I make have over looked it, but I didn't see anything that shows how to test for that function of the display. Also, do you carry the main board Part number: WB27X10775
Part number: WB27X10775
? Thanks for your info. It has benn excellent help. gpallen
gpallen  
#3 Posted : Monday, December 6, 2010 9:08:09 AM(UTC)
gpallen

Rank: Member

Groups: Registered
Joined: 4/8/2010(UTC)
Posts: 8

Originally Posted by: MicrowaveDisplaycom Go to Quoted Post
Now that you mention all that, it sounds like the option to display the time clock has gotten changed. From the owner's manual*:

OPTIONS
Press this button to set the Clock and access
the Beeper Volume, Clock Display ON/OFF,
Display Scroll Speed, Delayed Start and Night
Light features.

* We have two owner's manuals at our site here and here.

So you may not have a real problem at all.

I do not stock this board.


William,

I had already tried this several times and tried again with no luck. We were using the microwave and when the food was ready we took it out. A few minutes later I was in the kitchen and looked up to see what the time was and noticed it was blank. I just tried all the buttons again and was able to get it to beep, mute, timer light to come on etc, but still no main display. Is there a way to tell for sure which board for just the display. Everything seems to work except the top portion of the display. The way I read the service manual you sent me is that the tests will show if any of the funtion buttons are not working but doesn't actually show how to test for the upper display unless I have missed something. Any other suggestions or just toss a coin to see which board I replace.
Thanks again for all your help. gpallen
gpallen  
#4 Posted : Monday, December 6, 2010 11:00:55 AM(UTC)
gpallen

Rank: Member

Groups: Registered
Joined: 4/8/2010(UTC)
Posts: 8

Originally Posted by: MicrowaveDisplaycom Go to Quoted Post
I would unplug the connections between the smart board and the key panel board and look for any green, gray or black mineral deposits which would be evidence of moisture.

Also look for ring cracks on the connections where the connectors are soldered to the boards.

UserPostedImage

Then plug them all back in, plug the oven in, and try it again.

Other than that, it would require tests with a meter or scope or do the "plug and pray" swapping of boards, as so often happens when a "technician" works on a unit.


Thanks William. I will give this a try and let you know what happens.
gpallen
vloegy  
#5 Posted : Tuesday, November 15, 2016 5:55:39 PM(UTC)
vloegy

Rank: Member

Groups: Registered
Joined: 11/15/2016(UTC)
Posts: 1

GPallen: I know it's been several years since your post but did you end up getting your GE Advantium 120 microwave display to work? After reading your post, it's the same issue that I'm having with mine. Also, I know someone suggested to set the clock and see if that would fix it, however, since the display is completely blank, I can't see anything when selecting the Options button in order to set it. The only things that lights up is the picture of the little microwave when selecting "Options". I was trying to guess how many clicks of the dial to get to the clock, but no luck.
Users browsing this topic
Similar Topics
GE Advantium Microwave SCB1001KSS (Microwave Repair)
by MK82Man 3/12/2009 6:43:39 PM(UTC)
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.