Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Kucireks  
#1 Posted : Tuesday, November 16, 2010 10:24:12 AM(UTC)
Kucireks

Rank: Member

Groups: Registered
Joined: 11/16/2010(UTC)
Posts: 1

My Kitchenaid food processor KFP750WHO died yesterday. With the bowl and lid properly engaged, it makes a sick humming noise when the "ON" or "PULSE" buttons are pushed. The blade does not engage. I can easily spin the shaft by hand when the bowl is off. Is there any hope for her, or should I just go and buy a new one?
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
Melissa Jones  
#2 Posted : Tuesday, June 13, 2017 9:16:49 AM(UTC)
Melissa Jones

Rank: Member

Groups: Registered
Joined: 6/13/2017(UTC)
Posts: 2

I too have run into this problem with kitchenaid's food processor... I now use the Hamilton Beach 10-Cup Food Processor and could not be happier! I would recommend buying this processor for sure. Goodluck!
McGear10  
#3 Posted : Thursday, June 15, 2017 5:39:15 PM(UTC)
McGear10

Rank: Member

Groups: Registered
Joined: 6/4/2017(UTC)
Posts: 19

Yes, I think you should get a new one.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.