Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

New Topic Post Reply
Options
Go to last post Go to first unread
John05491  
#1 Posted : Thursday, November 11, 2010 12:28:54 PM(UTC)
Quote
John05491

Rank: Member

Groups: Registered
Joined: 11/11/2010(UTC)
Posts: 1

My SHE98 stopped working, when you try to turn the unit on to select a cylce it beeps but the displays (both the one on top of and on the front of door) do not light up. We cannot choose a cycle or start the unit.

I turned power off to the unit and re-applied it to see if that would reset anything but no change. I then assumed it must be a problem with either a button or the control unit (both in the same module) so I replaced the door mounted control unit. No luck.

There is a second control unit in the base but I really need help before I try any other parts.

Has anyone else seen this problem or have a troubleshooting chart?

Thanks
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
jporter584  
#2 Posted : Monday, January 31, 2011 10:19:02 AM(UTC)
Quote
jporter584

Rank: Member

Groups: Registered
Joined: 1/31/2011(UTC)
Posts: 2

I've had the same problem for a few months now. comes and goes. mostly comes. I had a technician here. he replaced 2 electronic components in the front but that did not solve the problem. although it did go away for about 2 months. now its back again. I'm going to try to fix it myself this time. ordering a control unit mounted in the bottom back of the unit. part number 666091.
phillyguy  
#3 Posted : Saturday, June 4, 2011 4:47:18 AM(UTC)
Quote
phillyguy

Rank: Member

Groups: Registered
Joined: 6/4/2011(UTC)
Posts: 1

I have the exact same issue with a Bosch SHX98M09UC

Were you guys ever able to get it working?

I found if I shut off the breaker for 30 seconds, I can get it to do one cycle, then it does the same thing. (Beep with no light)
jporter584  
#4 Posted : Saturday, June 4, 2011 4:57:31 AM(UTC)
Quote
jporter584

Rank: Member

Groups: Registered
Joined: 1/31/2011(UTC)
Posts: 2

it was the control unit. mounted at bottom right rear. part number part number 666091. just swap it.
schor  
#5 Posted : Monday, December 31, 2012 6:18:02 AM(UTC)
Quote
schor

Rank: Member

Groups: Registered
Joined: 12/31/2012(UTC)
Posts: 1

I had the exact same problem. Opened the front and took out the control board, yes took it out of the 666092 box and tried to order the part, looks like you cannot only order the board.

Then I found this thread and decided to not order 666092, put everything back together and it now works without replacing any parts.

I assume it will die eventually again.

How do I get to 666091 control unit? Do I take off the right side panel? How?

Schor
RobBow  
#6 Posted : Thursday, September 10, 2020 9:15:20 AM(UTC)
Quote
RobBow

Rank: Member

Groups: Registered
Joined: 9/10/2020(UTC)
Posts: 0
Canada

For those with a top (up facing) display, the display will not function with the door closed. It is possible that the door thinks it's closed, so you may get lucky and fiddle with the closure and sensor. It worked for me as these control boards are no longer manufactured and I'm just too cheap to call it quits!
Guest  
#7 Posted : Sunday, March 21, 2021 9:42:35 AM(UTC)
Quote
Guest

Rank: Guest

Groups:
Joined: 8/10/2018(UTC)
Posts: 0
United States
Location: 99556

Originally Posted by: RobBow Go to Quoted Post
For those with a top (up facing) display, the display will not function with the door closed. It is possible that the door thinks it's closed, so you may get lucky and fiddle with the closure and sensor. It worked for me as these control boards are no longer manufactured and I'm just too cheap to call it quits!


This was my problem....I was just testing it to make sure everything was hooked up properly before I put it in its place and thought it was broken because nothing would turn on. Just needed to open the door lol
Guest  
#8 Posted : Monday, April 19, 2021 12:43:39 PM(UTC)
Quote
Guest

Rank: Guest

Groups:
Joined: 8/10/2018(UTC)
Posts: 0
United States
Location: 99556

I just got a new bosch super silent dihwasher. Cant get it to change off automatic. I close the door. The red light comes on but beep 3 times after a minute and turns off. Very frustrating since it is new. We have ran it 3 times.
Guest  
#9 Posted : Monday, April 19, 2021 12:44:44 PM(UTC)
Quote
Guest

Rank: Guest

Groups:
Joined: 8/10/2018(UTC)
Posts: 0
United States
Location: 99556

I just got a new bosch super silent dihwasher. Cant get it to change off automatic. I close the door. The red light comes on but beep 3 times after a minute and turns off. Very frustrating since it is new. We have ran it 3 times.
Quick Reply Show Quick Reply
Users browsing this topic
New Topic Post Reply
Forum Jump  
You can post new topics in this forum.
You can reply to topics in this forum.
You can delete your posts in this forum.
You can edit your posts in this forum.
You cannot create polls in this forum.
You can vote in polls in this forum.