Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

New Topic Post Reply
Options
Go to last post Go to first unread
thisisdatis  
#1 Posted : Wednesday, November 24, 2021 1:09:08 PM(UTC)
Quote
thisisdatis

Rank: Member

Groups: Registered
Joined: 11/24/2021(UTC)
Posts: 0
Canada
Location: BC

I recently purchased a used JDS1750 FS Range. Since having it installed, we've tried using the oven a few times and find that the oven gets stuck in preheat mode, about 30-75 degrees below where it should be.

The oven itself has no problem reaching our desired temps, however, we have to go above what we are wanting to set it to in order to achieve that.

IE: if i want it set to 350f, it only gets to about 300, but if I set it to 425F, i can get it to 350F but it still remains in "pre-heating" mode as per the display on the screen.

Any ideas on what this could be?
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
ThatGuy  
#2 Posted : Thursday, November 25, 2021 1:19:39 PM(UTC)
Quote
ThatGuy

Rank: Advanced Member

Groups: Expert
Joined: 7/27/2010(UTC)
Posts: 1,395
United States
Location: near the middle of nowhere

Was thanked: 14 time(s) in 14 post(s)
Is your bake element getting hot? ( preheat uses broil and bake elements, baking uses just the bake element. ) You could have a bad temperature sensor or a bad computer or maybe this computer has an adjustment off-set for temperature.
Quick Reply Show Quick Reply
Users browsing this topic
New Topic Post Reply
Forum Jump  
You can post new topics in this forum.
You can reply to topics in this forum.
You can delete your posts in this forum.
You can edit your posts in this forum.
You cannot create polls in this forum.
You can vote in polls in this forum.