Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

New Topic Post Reply
Options
Go to last post Go to first unread
Bob McDonnell  
#1 Posted : Wednesday, July 21, 2021 11:32:11 AM(UTC)
Quote
Guest

Rank: Guest

Groups: Registered
Joined: 8/10/2018(UTC)
Posts: 0
United States
Location: 99556

My 4 year old Frigidaire upright freezer stopped working. I unplugged it and checked to see if coils were frozen and they were not frozen over. I plugged it back in and the fan runs and I can hear the compressor running. the temperature in the freezer when back to 0 degrees. The next morning the freezer had shut off again. I replaced the defrost timer and it still runs for several hours and shuts off. It will run only after being unplugged and turned back on again. Any ideas?
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
ThatGuy  
#2 Posted : Thursday, July 22, 2021 12:55:38 AM(UTC)
Quote
ThatGuy

Rank: Advanced Member

Groups: Expert
Joined: 7/27/2010(UTC)
Posts: 1,395
United States
Location: near the middle of nowhere

Was thanked: 13 time(s) in 13 post(s)
Could be a bad cold control/thermostat. Need a model number to get a better idea of what we are dealing with.
Guest  
#3 Posted : Thursday, July 22, 2021 3:52:39 AM(UTC)
Quote
Guest

Rank: Guest

Groups: Registered
Joined: 8/10/2018(UTC)
Posts: 0
United States
Location: 99556

It's a Frigidaire model # FFFU14F2QWJ. I put an OHM meter on the thermostat terminals and it registers when I rotate the dial from warm to cold. When I plug in the freezer it will run when I turn the thermostat to the coldest setting. The freezer temp went down to -20 after running non stop a couple of hours, then it shut and does not start again!
ThatGuy  
#4 Posted : Monday, July 26, 2021 11:43:01 AM(UTC)
Quote
ThatGuy

Rank: Advanced Member

Groups: Expert
Joined: 7/27/2010(UTC)
Posts: 1,395
United States
Location: near the middle of nowhere

Was thanked: 13 time(s) in 13 post(s)
When it should be running, but isn't, try tapping the thermostat knob lightly. If it comes on, your thermostat is sticking internally. Sorry about the delay. I don't get paid, just trying to help with something I know. Life gets in the way sometimes.
applesack37  
#5 Posted : Tuesday, July 27, 2021 3:25:17 AM(UTC)
Quote
applesack37

Rank: Member

Groups: Registered
Joined: 7/22/2021(UTC)
Posts: 0
United States
Location: New Hampshire

Thanks Thatguy,
I replaced the thermostat, $10.45 on Amazon, and the freezer is working perfectly again!
Quick Reply Show Quick Reply
Users browsing this topic
New Topic Post Reply
Forum Jump  
You can post new topics in this forum.
You can reply to topics in this forum.
You can delete your posts in this forum.
You can edit your posts in this forum.
You cannot create polls in this forum.
You can vote in polls in this forum.