Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
mikedbom  
#1 Posted : Wednesday, November 11, 2020 4:21:33 PM(UTC)
mikedbom

Rank: Member

Groups: Registered
Joined: 11/11/2020(UTC)
Posts: 0
United States
Location: CA

Model Number: 66513543N411

Dishwasher operates fine however it does not heat when any options (sani-rinse, high temp, heated dry) are enabled. When we first got it, there used to be lots of steam and hot dishes just after a cycle. Now the dishes are warm and wet.

I have completed the following checks:
  • High limit fuse - good continuity
  • Heater element - good continuity
  • Tested wires back to control board - all good


Just sat through a good portion of a cycle with all three of the options (sani-rinse, high temp, heated dry) on and the heater relay never fired. I can hear the pump relay firing on and off but the heater never registered 120V. I'm guessing my issue is the board but would like some input.

I also have not been able to find the diagnostic mode process for this machine. Would like to be able to fire the heater directly for troubleshooting. I only have the following buttons: Cycles, Delay, sani-rinse, high temp, heated dry, Start.

I can provide pics or more information as needed. Would really like to fix this with some knowledge behind my next move. Replacing the control board isnt cheap but neither is replacing the entire unit.

Thank you in advance.

Mike
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.