Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.



Go to last post Go to first unread
#1 Posted : Wednesday, August 28, 2019 7:12:35 PM(UTC)

Rank: Member

Groups: Registered
Joined: 3/13/2010(UTC)
Posts: 7

I have a Samsung ME16k3000AS in a rental property that is just over 2 yrs old. I already replaced the internal 20A fuse before the current renters moved in and don't know how well it worked leading up to that (evicted previous tenants). It worked for a few months and the renter called and said the microwave didn't work, they pressed start and the unit shut down. I figured same issue, the internal fuse was bad so I replaced the fuse again and blew as soon as I started the microwave. Now I'm thinking there is a bigger issue. I did some looking online and looks like the capacitor may be the issue, but wanted more feedback before I go and buy parts to throw at it.

What are possible causes of this?

See inside of your appliance - diagrams and part photos for virtually every model.

powered by
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.