Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.



Go to last post Go to first unread
#1 Posted : Monday, November 12, 2012 3:20:50 PM(UTC)

Rank: Member

Groups: Registered
Joined: 9/25/2012(UTC)
Posts: 2

After a power surge a few weeks ago (apparently caused by a log truck taking out the power lines), my range gave a weird error code: EE-214 M-214.

Pushing cancel cleared the code and it seemed to work fine until I cooked a roast the other day. I wanted 15 minutes of high heat (500) but when I went to turn it down, the bottom few buttons on the left side of the control panel would not work - "Other Options, Rapid Preheat, Clean, Convect, etc."

I reset it by throwing the breaker. The buttons worked again until a few hours later when the oven was completely cool - then the same buttons didn't work. I needed to proof some bread and thankfully programmed that into my presets - a button that did work. When the oven was warmed up a bit the buttons worked again. This morning they did not work when the oven was cold again.

Thoughts? Diagrams for how to check the connections between buttons and the ccontrol panel circuit? Which parts might need replacing? I have some circuits background and an multimeter if that would be helpful.

Thanks in advance - I need a working oven to feed my family especially with holidays drawing near.

See inside of your appliance - diagrams and part photos for virtually every model.

powered by
#2 Posted : Tuesday, November 13, 2012 4:48:56 PM(UTC)

Rank: Advanced Member

Groups: Senior Expert
Joined: 7/19/2007(UTC)
Posts: 27,455

Was thanked: 1 time(s) in 1 post(s)
Hi Tanya,

The problem can be a bad control panel (more likely) or a bad control board.

The instructions on how to check the key pad you can find in the attached tech sheet (pages 5 & 6). If you'll need the correct part numbers, post the end of the model number.

File Attachment(s):
16026930 - Dual fuel ranges JDS9865BD - JDS9860BD - JDS8850BD.pdf (1,193kb) downloaded 207 time(s).

You cannot view/download attachments. Try to login or register.
#3 Posted : Wednesday, June 26, 2019 3:19:29 PM(UTC)

Rank: Member

Groups: Registered
Joined: 6/26/2019(UTC)
Posts: 0
United States

I had a semi-similar problem with our Jenn-Air dual fuel stove. No catastrophic event; we gradually lost control button response over time until we were down to two numbers on the number pad. No fan, clock, timer, and, finally, no oven controls, so we couldn't bake. I just replaced the control board with a board from APP, and got the ee-214 m-214 error codes, and seven buttons working on the number pad but nothing else. Still no bake. I guess it could be the actual touch pad on the front, but if that were bad I wouldn't expect to get seven number buttons working again. Any thoughts? I rechecked connections and reinstalled the ribbon connection to the touch-pad, but no luck. Should I invest in a new front panel to get a new touch-pad, or is there something I missed (other then not getting a Jenn-Air in the first place).

UPDATE: I ordered a new control panel from APP, replaced the old one and the range now works. I don't necessarily regret replacing the control board. The original board was old and also subject to the high heat.

Edited by user Wednesday, July 3, 2019 1:36:30 PM(UTC)  | Reason: New information

Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.