Customer Support 7 days a week

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
mkemescher  
#1 Posted : Thursday, November 8, 2018 5:22:27 PM(UTC)
mkemescher

Rank: Member

Groups: Registered
Joined: 4/21/2008(UTC)
Posts: 1

Wondering if the microwave relay board WB27X10859 would be the cause a no cook condition and cause the 20 amp ceramic fuse to blow? When I put a 120 volt light across the fuse holder, the light comes on dimly when the door is opened. (37 volts AC found testing both ends of fuse holder. When the cook cycle is started, the light flashes very bright. The display shows the message "Power Failure" and shuts off the cycle. I have disconnected and tested all loads and have not found any shorted items,(light, fan, door switches, elements, hi voltage system). This microwave has a main control board, a relay board and a power board. Any ideas?
Sponsor
See inside of your appliance - diagrams and part photos for virtually every model.

powered by AppliancePartsPros.com
 
bestcar  
#2 Posted : Saturday, November 10, 2018 10:04:13 PM(UTC)
bestcar

Rank: Member

Groups: Registered
Joined: 11/10/2018(UTC)
Posts: 0

Do you want to say a connection?
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.